NTP und driftfile

Hier werden Probleme diskutiert und Fragen beantwortet. Hier kommt alles rein was mit Linux zu tun hat.
geloescht

NTP und driftfile

Beitrag von geloescht » Sonntag 15. Juli 2007, 11:55

Hallo Steckdösler,

ich will/muß mal wieder das Linux-Forum beleben.

Es geht um einen Rechner dessen Uhr deutlich falsch geht. Auf dem Rechner läuft der IPCOP und ein ntp-server.

Laut diesem Artikel (link) und Internet Recherchen soll der NTP die interne Uhr langsamer oder schnelle laufen lassen, je nachdem, was in der ntp.drift (vom NTP) hinterlegt wird. Leider scheint dieser Automatismus nicht zu funktionieren. Die Uhr läuft konsequent falsch!

http://www.dn-systems.de/press/ix.1203.134-138.pdf

Ich hatte im IPCOP-Forum schon eine längere Diskussion (Username: Alois) zum Thema, die aber nicht zum Erfolg führte!

Vielleicht weiss hier jemand was!?

Gruß


Alois

ohoyer
Null-Leiter
Beiträge: 3426
Registriert: Mittwoch 27. Dezember 2006, 13:10
Wohnort: Koblenz

Beitrag von ohoyer » Sonntag 15. Juli 2007, 17:45

Alois hat geschrieben:Hallo Steckdösler,

ich will/muß mal wieder das Linux-Forum beleben.

Es geht um einen Rechner dessen Uhr deutlich falsch geht. Auf dem Rechner läuft der IPCOP und ein ntp-server.

Laut diesem Artikel (link) und Internet Recherchen soll der NTP die interne Uhr langsamer oder schnelle laufen lassen, je nachdem, was in der ntp.drift (vom NTP) hinterlegt wird. Leider scheint dieser Automatismus nicht zu funktionieren. Die Uhr läuft konsequent falsch!

http://www.dn-systems.de/press/ix.1203.134-138.pdf

Ich hatte im IPCOP-Forum schon eine längere Diskussion (Username: Alois) zum Thema, die aber nicht zum Erfolg führte!

Vielleicht weiss hier jemand was!?

Gruß


Alois

Fragen: Wo steht der Server, gegen welchen ntp-server wird synchronisiert, wieviel Zeitversatz hat der Server bereits? Welches nptd-Programm wird benutzt?
Wenn die Abweichung zu gross ist, muss der admin erstmal per date-Befehl die Uhr richtig stellen, also sinngemaess:

ntpd stop
date "aktuelle Uhrzeit"
ntpd start

Bin gerade unterwegs, kann nachher noch was zu sagen, wenn ich im Hotel bin.

geloescht

Beitrag von geloescht » Sonntag 15. Juli 2007, 22:35

Hallo ohoyer,

wenn ich ntpd -v eingebe, dann bekomme ich folgende Versionsmeldung:

NTP - daemon Programm - Ver. 4.2.4-RC3

Die Synchronisierung erfolgt gegen einen Server ptbtime1.ptb.de

Der Zeitversatz ist erheblich (ca. -500 s in einer Stunde).
Wo steht der Server
Hessen, Darmstadt

Gruß und Danke für Informationen


Alois

geloescht

Beitrag von geloescht » Sonntag 15. Juli 2007, 23:05

Hallo ohoyer,

Beispiel für die Ungenauigkeit:

Um 22.37 wurde die Uhr nach einem genauen Zeitserver gestellt.

Um 23.02 erneut.

Zeitdifferenz: -133 Sekunden

Gruß

Alois

geloescht

Beitrag von geloescht » Sonntag 15. Juli 2007, 23:11

Hallo ohoyer,

mir fällt gerade auf, dass die 500 s nicht mehr stimmen. Vielleicht haben meine Maßnahmen hinsichtlich driftfile schon was bewirkt!

Gruß

Alois

Wanderer
Null-Leiter
Beiträge: 606
Registriert: Dienstag 27. Dezember 2005, 11:23
Wohnort: Hessen

Beitrag von Wanderer » Montag 16. Juli 2007, 10:28

Ansonsten frag doch mal im Debian-Forum nach: http://www.debianforum.de/forum/

Gruß,
Wanderer
Wanderer, kommst du nach Sparta, verkündige dorten, du habest uns hier liegen gesehn, wie das Gesetz es befahl.

geloescht

Beitrag von geloescht » Montag 16. Juli 2007, 11:07

Hallo Wanderer,

der IPCOP ist keine Debian Distribution :-( ! Das ist eine von allem unnötigen befreite Linux-Version.

Gruß

Alois

geloescht

Beitrag von geloescht » Montag 16. Juli 2007, 11:29

Hallo Wanderer,

ich habe eben festgestellt, dass die Hardwareuhr recht genau geht. Der Fehler wird offenbar woanders produziert.

hwclock --show

ergibt eine Zeit, die um 0,6 s abweicht

Date ergibt eine Zeit die um 7 min abweicht, obwohl die Uhr mit ntpdate nach einem Zeitserver um 10.41 Uhr gestellt wurde!

Gruß

Alois

ohoyer
Null-Leiter
Beiträge: 3426
Registriert: Mittwoch 27. Dezember 2006, 13:10
Wohnort: Koblenz

Beitrag von ohoyer » Montag 16. Juli 2007, 19:08

Alois hat geschrieben:Hallo Wanderer,

ich habe eben festgestellt, dass die Hardwareuhr recht genau geht. Der Fehler wird offenbar woanders produziert.

hwclock --show

ergibt eine Zeit, die um 0,6 s abweicht

Date ergibt eine Zeit die um 7 min abweicht, obwohl die Uhr mit ntpdate nach einem Zeitserver um 10.41 Uhr gestellt wurde!

Gruß

Alois
Dann mach mal folgendes: Alles, was mit ntp etc. zu tun hat, abdrehen, mit date die Uhrzeit neu stellen und mal die Drift über nen Tag beobachten- wenn die dann weiter driftet als ne Minute, schiessen irgendwelche Dinge quer, die auf Betriebssystemsebene das Ganze beeinflussen.

geloescht

Beitrag von geloescht » Montag 16. Juli 2007, 22:03

Hallo Ohoyer,
Dann mach mal folgendes: Alles, was mit ntp etc. zu tun hat, abdrehen, mit date die Uhrzeit neu stellen und mal die Drift über nen Tag beobachten- wenn die dann weiter driftet als ne Minute, schiessen irgendwelche Dinge quer, die auf Betriebssystemsebene das Ganze beeinflussen.
Dann brauchen wir nicht mehr weiter zu suchen. Das Driften liegt innerhalb einer Stunde bei ca. 10 Minuten!

Mein Verdacht ist eine Inkompatibilität zu ACPI. Das ist aber in GRUB auf acpi=off geschaltet. Weitere Möglichkeiten beim Start am IPCOP zu drehen habe ich noch nicht gefunden!

Gruß

Alois

Antworten